Explore Graph

Explore Graph

After data has been loaded, the Explore Graph page allows you to search for vertices in a graph, to discover nearby vertices which satisfy conditions of your choice, and to find the paths between vertices.

Below is an example of an exploration result:

The Explore Graph page is vertically divided into three parts, from left to right:

The Inner Navigation Bar

The menu options, from top to bottom, are the following:

The Parameter Panel

Set filters, conditions and other parameters for the selected option from the Inner Navigation Bar.

The Graph Exploration Panel

The exploration result is displayed in this panel.

Adjust the results display, take a snapshot of the display, and modify selected data objects in the result.

The menu buttons, from left to right, are the following:

  • Open exploration history : Open a previously saved graph exploration result.

  • Save exploration : Save the current visualization result.

  • Save screenshot : Save the current visualization result as a png file.

  • Change layout : Arrange the vertices according to one of the built-in layout patterns, such as sphere, tree, circle, or force.

  • Locate vertices in result : Search the exploration result by vertex id or attribute value.

  • Only show selections : First select one or more objects. Clicking the button will hide all the objects which are not selected.

  • Hide : First select one or more objects. Clicking the button will hide the selected vertices and edges (or all if none is selected).

  • Undo : Undo the last change to the visualization result set (that is, changes to which objects are included in the result set).

  • Redo : Redo the most recent undone change to the visualization result set (that is, changes to which objects are included in the result set).

  • Add new vertex : Add a new vertex into the visualization result as well as to the graph database .

  • Add new edge : Add a new edge into the visualization result as well as to the graph database .

  • Edit attributes : Change the attributes of the selected object in the visualization result as well as the graph database .

  • Delete selected elements : Delete the selected elements from the visualization result as well as the graph database .

  • Change settings : Select which attribute values to display with each vertex or edge type. Enable/disable popup display of all attributes when the cursor hovers over a vertex or edge.

The Parameter Panel can be hidden by clicking its corresponding button in the Explore Graph Menu.

Search Vertices In Graph

The first button in the Explore Graph Menu is the "search vertices" option. This option lets you select an initial set of vertices for your exploration. It is also the default option when you first enter the Explore Graph page. Clicking the button again will hide the Parameter Panel to increase space for the Graph Exploration Panel.

Search Vertices by ID

Choose vertex type from the Vertex type dropdown list, and enter the vertex id in the Vertex id input box, then click Search button. If there is one vertex that matches the vertex type and id, it will be shown in Graph Exploration panel.

Let GraphStudio pick vertices

If you don't have a particular vertex ID in mind, you can have GraphStudio pick some vertices for you. In the Parameter Panel, enter a number of vertices to pick, and click on Pick vertices button. The explorer will pick this number of vertices for each vertex type included in your search.

The Configuration section in the Parameter Panel specifies which types of vertices you want to include in your selection. By default, all vertex types are selected. Uncheck some boxes if you want to narrow your selection.

Search vertices with attribute filters

You can control vertex search in finer granularity by creating attribute filters. Click the filter buttonto the right of any vertex type. In the pop up window, you can create a condition involving attributes of the vertex type. The user experience is same as creating data filters when you do data mapping. Here is an example attribute filter for searching Company vertices with registered_capital >= 50,000:

Click ADD, then the filter condition is shown below Company vertex type:

Click Pick vertices button​ again, TigerGraph will search for up to 5 Company vertices with a registered_capital >= 50,000.

Expand From Vertices

The second button in the Explore Graph Menu is the "Expand from vertices" option. "Expand" in this context means find 1-step or multi-step neighbors of the selected vertices. Clicking the button again will hide the Parameter Panel to increase space for the Graph Exploration Panel. To expand from vertices, you need to have at least one selected vertex in the Graph Exploration Panel. If no vertices are visible, please refer to the previous section "Search Vertices in Graph" to search for some vertices.

Choose Vertices To Expand

There may already be some selected vertices from the previous action. A vertex that is selected has a thick gray border around it. The standard click and shift-click behaviors for selecting one or multiple objects applies:

  • Click on a vertex to select it. Any previously selected objects are unselected.

  • Shift-click on an unselected object to add it to the selection set.

  • Shift-click on a selected object to remove it from the selection set.

To unselect all vertices, click on a blank area of the panel.

Set Expansion Conditions

GraphStudio lets you expand multiple steps from the target vertices, as long as the resulting number of vertices and edges does not exceed the limit for visualization (default limit is 5000 vertices and 10000 edges). The conditions for each expansion step are specified independently.

In the Parameter Panel, set the conditions for each expansion step:

  • Maximum number of edges include for each vertex. The effect is that vertices which have more neighbors than this limit will not have all their neighbors included in the expansion.

  • Edge types and the attribute filter for each edge type to include.

  • Target vertex types and the attribute filter for each vertex type to include.

Initially, the expansion conditions panel for only one expansion step is shown. Click "Add Expansion Step" to add more expansion steps.

Similarly, you can remove expansion steps by clicking the "Remove Expansion Step" button.

Expand

After setting the conditions for each expansion step, click on the "Expand" buttonto perform the expansion. The Graph Exploration Panel will be updated to include the expansion result. The expansion starting vertices will be highlighted with a white border. Here is a sample two-step expansion starting from 2 vertices:

Find Paths Between Two Vertices

The third button in the Explore Graph Menu is the "Find paths" option. This option finds paths between two vertices with your specified conditions. Clicking the button again will hide the Parameter Panel.

Choose Starting Vertex and Destination Vertex

The top section of the Parameter Panel asks for your desired starting vertex and destination vertex.

There are two ways to provide this information. Each of the two vertices can be selected by either method.

If you know the ID and vertex type for a vertex, you can choose vertex type from dropdown list and type vertex id in the input box. The vertex does not need to be currently displayed in the Graph Exploration Panel.

If the vertex you want is already displayed in the Graph Exploration Panel, a more convenient way is the following:

  1. Click on the input box.

  2. Click on the desired vertex in the Graph Exploration Panel. Then, GraphStudio will automatically fill in the values for you.

You can click the swap icon (two green arrows) at right to switch the starting vertex and the destination vertex.

Set Conditions For Paths

GraphStudio provide three types of path searches:

  1. One shortest path: search for and highlight a shortest path between the two vertices.

  2. All shortest paths: search for and highlight all shortest paths between the two vertices.

  3. All paths: search for and highlight all valid paths between the two vertices.

Since path-finding queries may have high computational cost if the graph is very large, a parameter is available to limit the path length.

In addition to the search type and the maximal length, you can also specify the valid vertex types and edge types and their attribute conditions which may be included in the paths.

Find Paths

After selecting the endpoint vertices and setting the search conditions, click on the "Find Paths" buttonto start the search.

Find Connections Between Multiple Vertices

The fourth button in the Explore Graph Menu is the "Find connections" option. Given a set of starting vertices, this feature finds a "connection community" which is defined as follows:

  1. For each pair of vertices in the vertex set, if there is a shortest path no longer than the maximum path length parameter, include that path in the result.

  2. The final result is the union of all of these shortest paths (one path per vertex pair).

This feature is equivalent to running the "Show One Shortest Path" option for each pair of vertices in the selected set.

Choose Vertices for Finding Connections

Click on a vertex to select it. Use shift-click to select more than one object. Each time you select another vertex, it will be added to the list in the Parameter Panel.

Set Conditions For Connection Finding

Since this query may have high computational cost if the graph is very large, a parameter is available to limit the path length.

You can also specify the valid vertex types and edge types which may be included in the connections.

Find Connections

After selecting the vertices and setting the search conditions, click on the "Find Connection Paths" buttonto start the search.

Run GSQL Queries

If you have written and installed some GSQL queries (see more at Write Queries), you can run the queries mixed with the graph exploration functionalities mentioned above.

Click the fifth button in the Explore Graph Menu, which is the "Run queries" option​. In the dropdown list, choose the query you want to run. Input the parameters and click Run query button. The query execution result subgraph will be merged with previous graph exploration result and highlighted:

Allowing running GSQL queries mixed with other graph exploration functionalities enables better data analysis possibilities since you can refer to your previous exploration result, and keep gaining insights from your data.

Graph Exploration Panel Options

After you have a subgraph displayed in the Graph Exploration Panel, you can use the buttons in the Explorer View Menu to customize the display. You can even make modifications to the graph database itself.

Change Layout

Click the Change Layout buttonto select one of the built-in layout styles for systematic arrangement of the vertices. The Change Layout popup menu shows a sample of each layout style, for a dummy graph.

Locate Vertex In Result

The Locate Vertex In Result featuresearches for and then zooms in on vertices which match the given value for ID and/or attribute. For example, if you type "Mary" in the Locate Vertices in Result popup window, and have both of the checkboxes selected, then this feature will look for any vertices where "Mary" is an exact match for either the ID or any of the attribute values. Those vertices will be selected (and all other objects will be unselected). The display will zoom in to focus on the selected objects.

The vertices with the matching ID or attributes will be selected:

Show Selected Vertices And Edges

Click the Show Selections buttonto hide all the vertices and edges which are not currently selected. However, if the two endpoints of an edge are selected, the edge will be selected as well. Also, if nothing is selected, nothing will be hidden.

Hide Vertices And Edges

Click the Hide buttonto hide the currently selected vertices and edges. If nothing is selected, all vertices and edges in the Graph Exploration Panel will be hidden.

Undo And Redo

The Explore Graph page records the whole history of the current session's changes to the visualization result set. Click the Undo and the Redo buttons to go back or forward in the history.

Add New Vertex

Click the Add New Vertex buttonto add a new vertex to the graph database. The Add New Vertex window will pop up. Choose a vertex type and then fill in values for the ID and the attributes. Click ADD and the vertex will be inserted into the TigerGraph database. It will also be shown in the Graph Exploration Panel.

Add New Edge

Click the Add New Edge buttonto add a new edge to the graph database. Next, click the source vertex of the edge in the Graph Exploration Panel, and then click the target vertex of the edge. Then the Add New Edge panel will pop up. Choose the edge type from the dropdown menu. Only types that match the two vertices you selected are shown. (It is possible that there are no eligible edge types). Fill in values for attributes and click ADD. Your new edge will be inserted into the TigerGraph database. It will also be shown in the Graph Exploration Panel.

Edit Attributes

To edit the attributes of one vertex or edge, select one object and then click the Edit Attributes button. The edit attributes panel will pop up.

When you finish editing, click the Update button to apply the change.

Delete Vertices And Edges

To delete vertices or edges, select the objects you want to delete, and click the Delete Selected Elements button.

Save and Open Graph Exploration Result

When you find something interesting during exploration and want to save the result as a picture, you can click the Save Exploration button. In the popup window, you can give the result a file name and an optional description, then click Save:

In the future, you can open a previously saved exploration result by clicking the Open Exploration History buttonand choose one result from the list:

Save Screenshot

When you find something interesting during exploration and want to save the result as a picture, you can click the Save Screenshot button. The exploration result will be saved as a PNG picture to your local file system.

Change Settings

To change graph exploration settings by clicking Settings button. Currently you can select what attributes to show for each vertex type and edge type, and set whether to show an object's detailed information in a popup tooltip when the cursor hovers over it. Click Apply and the new settings will take effect.

In the example below, the ID and gender for Person vertices are shown. The ID and the registered_capital attribute for Company vertices are shown.

You can also config the label size of vertices and edges.

Other than the above, you can also config vertex and edge size and color to augment the visualization in settings. It is so important that we will use next independent section to introduce.

Augment Graph Visualization Result

Set different colors according to attributes and accumulator values

By default each vertex and edge is rendered as the color you selected in Schema Design page. However, if you want to emphasize some vertices and edges in your visualization result, you can config a different color for them by creating a set of conditions, and assign a different color for each condition. Then vertices and edges satisfying the conditions will be rendered as the newly assigned color. In the Color section of Settings panel, first choose the vertex or edge type you want to set colors, then click the add button. A new color config entry appears:

Click the Edit color config button, in the pop up window choose red color, and build a condition specifying @PageRankScore >= 1.0:

Click ADD, and the condition and updated color is shown in the Color settings section:

Similarly, you can add another color config that @PageRankScore between [0.5, 1) will be green. The final Color settings section will look like:

Click the APPLY button, then the different vertices will be rendered as different colors based on their page rank score ranges:

Similarly, you can change color of edges.

If you want to cancel one color configuration, just click the remove buttonto the right side of that configuration.

Set different vertex radius and edge thickness according to attributes and accumulator values

By default all vertices are of radius 40, and all edges are of thickness 2. You can config vertex radius and edge thickness according to their attributes or numeric accumulator values of GSQL query result. A classical example is page rank. You can set vertices radius proportional to their page rank values, then the importance of each vertex is visually apparent according to its size.

First choose the vertex type you want to config its radius, then click the Edit buttonin Radius section. In the popup window you can create the radius expression:

After click ADD button, the radius expression will be shown in Radius section:

After click APPLY button, the vertices will be rendered in different size according to the expression value:

Similarly, you can config different thickness for the edges.

If you want to cancel the vertex radius or edge thickness configuration, click Edit button in Radius or Thickness section, in the pop up window choose None in the top level expression dropdown list:

Click ADD, then click APPLY. The size will be changed back to uniform.

The size and color can be configured at same time. Here is the effect of setting both color and size for page rank vertices: